Increased card failure rate
Incident Report for Assembly Payments
Resolved
This incident has been resolved.
Posted May 30, 2020 - 22:51 AEST
Monitoring
We've identified an issue with a upstream credit card processor and unable to process card payments at this time. We are monitoring for updates on their side. They are working to rectify the problem as a matter of urgency and we expect to be back online shortly.

We will update as the incident progresses.
Posted May 30, 2020 - 22:25 AEST
This incident affected: Payment Processing (Card Processing).