BPay transaction processing delayed
Incident Report for Zai
Resolved
Normal processing has resumed.
Posted Mar 29, 2021 - 12:50 AEDT
Investigating
We have been advised of a BPay processing delay from our upstream provider. Our partner is addressing the hold-up as a priority and will provide more information as it becomes available.
Posted Mar 29, 2021 - 12:21 AEDT
This incident affected: Payment Processing (Batch).